Update PHP 5.3 trong Kloxo

Việc update lên PHP 5.3 trong Kloxo được cho là khuyến cáo không nên update vì còn nhiều các vấn đề lên quan đến script và zend. Tuy nhiên, nội dung thực hiện update version cho PHP trong Kloxo dưới đây chúng ta cũng nên tham khảo. Hiện tại Kloxo Panel chưa có thời gian để test, bạn nào thực hiện update thành công thì comment để mọi người biết thêm thông tin.

Chi tiết như sau:

We have heard that PHP 5.2 support is declared dead, and immediately recommended that users migrate to the latest version of php 5.3, it does make me worry too considering I was also struggling in web development as well as I want a new version of my php. I am searching out how to upgrade my vps that happen to use Kloxo, after hunting long enough I actually found this script:

#
#
yum check-update php
yum update php

When I try, it is effective in Kloxo repo but apparently still php 5.2 available for update at the time this article was written. nah after that I found an article (I forget the exact address) which gives the following script:

#
yum install php53

Before you perform the upgrade php, please see your php version first by:

#
php-v

nah there in my vps replies:

PHP 5.2.17 (cli) (built: February 16 2012 23:29:39)
Copyright (c) 1997-2010 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2010 Zend Technologies

well, after that we can not directly install php 5.3 but first we must meremove php we use, how is:

#
#
yum remove php
yum remove php-common

well after that we install php 5.3 as follows:

#
yum install php53

Well, the above script will be installed php 5.3 but we will experience an error when we access the php files that connect to mysql, why? Because apparently extensions for mysql itself has not been installed. we can install it by:

#
yum install php53-mysql

After that, restart apache to see changes in the way:

#
yum httpd restart

nah please check back current php version, if true it would appear the following reply:

PHP 5.3.3 (cli) (built: Feb 22 2012 19:37:49)
Copyright (c) 1997-2010 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies

Reply above 5.3 indicates that the php installation has been successful.